1054. 求平均值 (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。
输入样例1:7 5 -3.2 aaa 9999 2.3.4 7.123 2.35输出样例1:
ERROR: aaa is not a legal number ERROR: 9999 is not a legal number ERROR: 2.3.4 is not a legal number ERROR: 7.123 is not a legal number The average of 3 numbers is 1.38输入样例2:
2 aaa -9999输出样例2:
ERROR: aaa is not a legal number ERROR: -9999 is not a legal number The average of 0 numbers is Undefined
开始分类讨论了很多情况,最后还WA了一个数据点
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n;
cin>>n;
double tot=0;
int cnt=0;
for(int i=1;i<=n;i++)
{
string s;
cin>>s;
if(s[0]=='-'&&s.length()==1)
{
cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
continue;
}
int cntpoint=0;
bool fff=0;
int len=s.length();
if(s[0]=='.'||(s[0]=='-'&&s[1]=='.')||s[len-1]=='.')
{
cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
}
else
{
for(int i=0;i<len;i++)
{
if(s[i]=='.') cntpoint++;
if(i!=0&&s[i]=='-') fff=1;
}
if(cntpoint>=2||fff) cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
else {
int ans=0;
bool ff=1;
int i;
for(i=0;i<len;i++)
{
if(s[i]=='-') continue;
if(!isdigit(s[i])&&s[i]!='.')
{
cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
ff=0;
break;
}
}
if(!ff) continue;
for(i=0;i<len;i++)
{
if(s[i]=='-') continue;
if(s[i]=='.') break;
ans=ans*10+s[i]-'0';
}
double ans1=0;
int cc=0;
for(int j=len-1;j>i;j--)
{
cc++;
ans1=ans1/10.0+(s[j]-'0')/10.0;
}
if(cc>=3)
{
cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
}
//cout<<ans<<" "<<ans1<<endl;
else {
if(ans+ans1<=1000)
{
cnt++;
if(s[0]!='-')
tot+=ans+ans1;
else tot-=ans+ans1;
}
else
{
cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
}
//cout<<cnt<<" "<<tot<<endl;
}
}
}
}
if(cnt>=2)
printf("The average of %d numbers is %.2lf",cnt,tot/cnt);
else if(cnt==0)
printf("The average of %d numbers is Undefined",cnt);
else printf("The average of 1 number is %.2lf",tot);
return 0;
}
后来使用了sscanf和sprintf
几行代码解决问题
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n,cnt=0;
double tmp,tot=0;
char a[100],b[100];
cin>>n;
for(int i=0;i<n;i++)
{
scanf("%s",a);
sscanf(a,"%lf",&tmp);
sprintf(b,"%.2lf",tmp);
int flag=0;
for(int j=0;j<strlen(a);j++)
{
if(a[j]!=b[j]) flag=1;
}
if(flag||tmp<-1000||tmp>1000)
{
cout<<"ERROR: "<<a<<" is not a legal number"<<endl;
}
else
{
cnt++;
tot+=tmp;
}
}
if(cnt>=2)
printf("The average of %d numbers is %.2lf",cnt,tot/cnt);
else if(cnt==0)
printf("The average of %d numbers is Undefined",cnt);
else printf("The average of 1 number is %.2lf",tot);
return 0;
}