PAT甲级 1023. Have Fun with Numbers (20)

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

一个由0到9排列组合的数判断它乘以2以后是不是同样由这些数排列组合得到
#include <cstdio>
#include <string>
#include <iostream>
using namespace std;
int cnt1[10] = { 0 }, cnt2[10] = {0};

int main(){
    string s;
    cin >> s;
    string s2 = s;
    for (int i = 0; i < s.size(); i++){
        cnt1[s[i] - '0']++;
    }
    int carry = 0;
    for (int i = s.size() - 1; i >= 0; i--){
        s2[i] = ((s[i] - '0') * 2 + carry )% 10 + '0';
        carry = ((s[i] - '0') * 2 + carry) / 10;
    }
    if (carry){
        char c = carry + '0';
        cout << "No\n" <<c<< s2 << endl;
        return 0;
    }
    for (int i = 0; i < s2.size(); i++){
        cnt2[s2[i] - '0']++;
    }
    bool flag = true;
    for (int i = 0; i < 10; i++){
        if (cnt1[i] != cnt2[i]){
            flag = false;
            break;
        }
    }
    if (flag) cout << "Yes" << "\n" << s2 << endl;
    else cout << "No\n" << s2<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值