1023. Have Fun with Numbers (20)【字符串操作】——PAT (Advanced Level) Practise

题目信息

1023. Have Fun with Numbers (20)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

解题思路

字符串模拟乘2操作

AC代码

#include <cstdio>
#include <cstring>
#include <map>
using namespace std;

char s[25], r[25];
map<int, int> sm, rm;
int main()
{
    gets(s+1);
    int len = strlen(s+1);
    for (int i = len; i > 0; --i){
        ++sm[s[i] - '0'];
        r[i] += (s[i] - '0') * 2;
        if (r[i] >= 10){
            ++r[i-1];
            r[i] -= 10;
        }
        ++rm[r[i]];
    }
    if (r[0] > 0){
        ++rm[r[0]];
    }
    printf("%s\n", (rm == sm) ? "Yes":"No");
    if (r[0] > 0) printf("%d", r[0]);
    for (int i = 1; i <= len; ++i){
        printf("%d", r[i]);
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值