POJ 1286 A - Necklace of Beads(Polya计数)

Necklace of Beads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8401 Accepted: 3502

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39


题意:3种颜色组成一串珠子,问有几种组成,旋转对称后相同的不算。
思路:Polya计数,讨论旋转i个珠子有gcd(i,n)个置换群
对称情况分奇偶讨论,详细体现在代码
#include<iostream>
#include<cstdio>
#include<math.h>
#include<algorithm>
using namespace std;
typedef long long ll;

int main()
{
    int n;
    while(cin>>n,n!=-1)
    {
        if(n==0) 
        {
            cout<<0<<endl;
            continue;
        }
        ll kind1,kind2;
        kind1=kind2=0;
        for(int i=0;i<n;i++)
        {
            kind1+=(ll)pow(3,__gcd(i,n));
        }
        if(n&1)
        {
            kind2=(ll)n*(ll)pow(3,n/2+1);
        }
        else
        {
            kind2=(ll)(n/2)*(ll)(pow(3,n/2)+pow(3,n/2+1));
        }
        cout<<(kind1+kind2)/(2*n)<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值