PAT甲级 1049. Counting Ones (30)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5

#include<iostream>
#include<cstdio>
#include<string.h>
#include<math.h>
using namespace std;

int CntOne(int n)
{
	int cnt=0;
	int wei=0;
	int m=n;
	while(m)
	{
		wei++;
		m/=10;
	}
	int cur=0;
	for(int i=1;i<=wei;i++)
	{
		if(cur==0) cur=1;
		else cur*=10;
		int h=(n/cur)/10;
		int l=n%cur;
		int c=(n-h*cur*10-l)/cur;
		if(c==0){
			cnt+=(h*cur);
		}
		else if(c==1)
		{
			cnt+=(l+1+h*cur);
		}
		else 
		{
			cnt+=(h*cur+cur);
		}
	}
	return cnt;
}

int main()
{
	int n;
	cin>>n;
	cout<<CntOne(n);
		cin>>n;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值