[UVa 11584]Partitioning by Palindromes

Problem Description

We say a sequence of char- acters is a palindrome if it is the same written forwards and backwards. For example, ‘racecar’ is a palindrome, but ‘fastcar’ is not.
A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race’, ‘car’) is a partition of ‘racecar’ into two groups.
Given a sequence of charac- ters, we can always create a par- tition of these characters such that each group in the partition is a palindrome! Given this ob- servation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palin- drome?
For example:
• ‘racecar’ is already a palindrome, therefore it can be partitioned into one group.
• ‘fastcar’ does not con- tain any non-trivial palin- dromes, so it must be par- titioned as (‘f’, ‘a’, ‘s’, ‘t’, ‘c’, ‘a’, ‘r’).
• ‘aaadbccb’ can be parti- tioned as (‘aaa’, ‘d’, ‘bccb’).

Input

Can you read upside-down?
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

Output

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1 7 3

My Problem Report

简单的线性DP,技巧在于预处理用is[i][j]记录字串(i,j)是否是回文串。不知大家有没有发现,这样的预处理本质上和记忆化搜索相同,可以避免重复计算。

My Source Code

//  Created by Chlerry in 2015.
//  Copyright (c) 2015 Chlerry. All rights reserved.
//

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <cstring>
#include <climits>
#include <string>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define Size 1010
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array, x) memset(array,x,sizeof(array))
typedef pair<int,int> P;

string a;
bool is[Size][Size];
int f[Size];
int main()
{
    // freopen("in.txt","r",stdin);
    int T;cin>>T;
while(T--)
{
    cin>>a;
    mem(is,0);
    for(int i=0;i<a.size();i++)
    {
        for(int j=0;i-j>=0 && i+j<a.size();j++)
            if(a[i-j]==a[i+j])
                is[i-j][i+j]=1;//,cout<<i-j<<','<<i+j<<endl;
            else
                break;
        for(int j=0;i-j>=0 && i+1+j<a.size();j++)
            if(a[i-j]==a[i+1+j])
                is[i-j][i+1+j]=1;//,cout<<i-j<<','<<i+1+j<<endl;
            else
                break;
    }
    f[0]=1;
    for(int i=1;i<a.size();i++)
    {
        f[i]=is[0][i]?1:f[i-1]+1;
        for(int j=0;j<i;j++)
            if(is[j+1][i])
                f[i]=min(f[i],f[j]+1);
    }
    cout<<f[a.size()-1]<<endl;
}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值