UVa 11584 Partitioning by Palindromes

Partitioning by Palindromes

We say a sequence of characters isa palindromeif it is the same writtenforwards and backwards. For example, 'racecar' is a palindrome, but'fastcar' is not.

ACM: <wbr>uva <wbr>11584 <wbr>-



partition of a sequenceof characters is a list of one or more disjoint non-empty groups ofconsecutive characters whose concatenation yields the initialsequence. For example, ('race', 'car') is a partition of 'racecar'into two groups.

Given a sequence of characters, we can alwayscreate a partition of these characters such that each group in thepartition is a palindrome! Given this observation it is natural toask: what is the minimum number of groups needed for a given stringsuch that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can bepartitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so itmust be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with thenumber n of test cases.Each test case consists of a single line of between 1 and 1000lowercase letters, with no whitespace within.

For each test case, output a line containing theminimum number of groups required to partition the input intogroups of palindromes.

Sample Input

3

racecar

fastcar

aaadbccb

Sample Output

1

7

3

经典DP,解法参照紫书,先用O(n2)的代价预处理字符串:re[i][j]表示从下标i到j的子串是否是回文串。dp[i]表示0~i能划分的最少回文串数,状态转移:dp[i]=min(dp[i],dp[j]+1),AC代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
const int maxn=1000+5;
const int INF=1<<30;
int dp[maxn];
bool re[maxn][maxn];
int main()
{
    int n;
    string a;
    cin>>n;
    while(n--)
    {
        memset(re,false,sizeof(re));
        cin>>a;
        int len=a.length();
        dp[0]=0;
        for(int i=1;i<=len;++i) dp[i]=INF;
        for(int i=0;i<len;++i)
        {
            int l=i,r=i;
            while(a[l]==a[r]&&l>=0&&r<len)
                re[l+1][++r]=true,--l;
            if(i+1<len)
            {
                l=i,r=i+1;
                while(a[l]==a[r]&&l>=0&&r<len)
                    re[l+1][++r]=true,--l;
            }
        }
        for(int i=1;i<=len;++i)
            for(int j=0;j<i;++j)
                if(re[j+1][i]) dp[i]=min(dp[i],dp[j]+1);
        cout<<dp[len]<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值