[Codeforces Round #318 ]Bear and Blocks

Problem Description

Limak is a little bear who loves to play. Today he is playing by destroying block towers. He built n towers in a row. The i-th tower is made of hi identical blocks. For clarification see picture for the first sample.

Limak will repeat the following operation till everything is destroyed.

Block is called internal if it has all four neighbors, i.e. it has each side (top, left, down and right) adjacent to other block or to the floor. Otherwise, block is boundary. In one operation Limak destroys all boundary blocks. His paws are very fast and he destroys all those blocks at the same time.

Limak is ready to start. You task is to count how many operations will it take him to destroy all towers.

Input

The first line contains single integer n (1 ≤ n ≤ 105).

The second line contains n space-separated integers h1, h2, …, hn (1 ≤ hi ≤ 109) — sizes of towers.

Output

Print the number of operations needed to destroy all towers.

Sample Input

6
2 1 4 6 2 2

Sample Output

3

input

7
3 3 3 1 3 3 3

output

2

Note

The picture below shows all three operations for the first sample test. Each time boundary blocks are marked with red color.
这里写图片描述
After first operation there are four blocks left and only one remains after second operation. This last block is destroyed in third operation.

My Problem Report

这道题我一开始以为可以找到规律。每一次操作都会把左右两端的方块全部给干掉,这样我们只需要找到底层最中间的那个方块,依次向左右两边遍历即可,效率是O(n)。
这个算法有个致命的bug,就是这个我假想中的“最中央方块”可能是错误的,我所找到的最中央方块并不是真正意义的上的最中央方块。
后来想一下,其实不用那么复杂,从左往右,从右往左分别做一次DP就好了。

My Source Code

//  Created by Chlerry in 2015.
//  Copyright (c) 2015 Chlerry. All rights reserved.
//

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <cstring>
#include <climits>
#include <string>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define Size 100000
#define ll long long
#define mk make_pair
#define pb push_back
#define mem(array, x) memset(array,x,sizeof(array))
typedef pair<int,int> P;

int n,a[Size],fl[Size],fr[Size],ans;
int main()
{   
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>a[i];
    fl[0]=fr[n-1]=1;
    for(int i=1;i<n;i++)
    {
        fl[i]=min(fl[i-1]+1,a[i]);
        fr[n-i-1]=min(fr[n-i]+1,a[n-i-1]);
    }
    for(int i=0;i<n;i++)
        ans=max(ans,min(fl[i],fr[i]));
    cout<<ans<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值