Fansblog HDU - 6608

Farmer John keeps a website called ‘FansBlog’ .Everyday , there are many people visited this blog.One day, he find the visits has reached P , which is a prime number.He thinks it is a interesting fact.And he remembers that the visits had reached another prime number.He try to find out the largest prime number Q ( Q < P ) ,and get the answer of Q! Module P.But he is too busy to find out the answer. So he ask you for help. ( Q! is the product of all positive integers less than or equal to n: n! = n * (n-1) * (n-2) * (n-3) *… * 3 * 2 * 1 . For example, 4! = 4 * 3 * 2 * 1 = 24 ) 

Input

First line contains an number T(1<=T<=10) indicating the number of testcases. 
Then T line follows, each contains a positive prime number P (1e9≤p≤1e14) 

Output

For each testcase, output an integer representing the factorial of Q modulo P. 

Sample Input

1
1000000007

Sample Output

328400734

p前面的第一个素数m与p的间隔大概在log p,m较大不能直接求m!,但我们可以通过威尔逊定理求得(p-1)!再除以m+1到p-1之间的数求得m!。

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<set>
#include<vector>
#include<iostream>
#include<time.h>
using namespace std;
const int maxn=1e7+10;
const double exc=1e-7;
long long mod;
int cnt;
bool vis[maxn+10];
long long prime[maxn+10];
void getprime()
{
    for(int i=2; i<=maxn; i++)
    {
        if(!vis[i])
            prime[cnt++]=i;
        for(int j=0; j<cnt&&i*prime[j]<=maxn; j++)
        {
            vis[i*prime[j]]=1;
            if(i%prime[j]==0)
                break;
        }
    }
}
bool isprime(long long n)
{
    for(int i=0; i<cnt&&prime[i]*prime[i]<=n; i++)
    {
        if(n%prime[i]==0)
        {
            return false;
        }
    }
    return true;
}
long long fastmul(long long a,long long b)
{
    long long ans=0;
    while(b)
    {
        if(b&1)
            ans=(ans+a)%mod;
        a=(a+a)%mod;
        b>>=1;
    }
    return ans%mod;
}
long long fastpow(long long a,long long b)
{
    long long ans=1;
    while(b)
    {
        if(b&1)
            ans=fastmul(ans,a);
        a=fastmul(a,a);
        b>>=1;
    }
    return ans;
}
int main()
{
    int t;
    getprime();
    scanf("%d",&t);
    while(t--)
    {
        long long p,m;
        scanf("%lld",&p);
        mod=p;
        m=p-1;
        while(!isprime(m)) m--; 
        long long ans=p-1;
        for(long long i=p-1; i>=m+1; i--)
            ans=fastmul(ans,fastpow(i,p-2));
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值