1140 Look-and-say Sequence(20 分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

题意:

如果我们把 1 作为Look-and-say 数列的第一项,那么,它的前几项是这样的:

1, 11, 21, 1211, 111221, 312211, 13112221, 1113213211, ...

在确定了Look-and-say 数列的第一项之后,就可以根据前一项确定后一项的值了,在上面的示例中,我们把 1 作为此种数列的第一项,那么,就可以这样来推导它的其余项了:

第1个是 1 时,记作 1;

第2个是读前一个数 "2 个1", 记作 21;

第3个是读前一个数 "1个2, 1个1", 记作 1211;

第4个是读前一个数 "1个1,1个2,2个1", 记作 111221;

//freopen("d://in.txt","r",stdin);
#include<iostream>
#include<string>
#include<fstream>
using namespace std;
int main(){
	int n;
	string s;
	cin >> s >> n;
	for(int i=1; i<n; i++){
		string t;
		for(int j=0; j<s.length(); j++){
			int cnt=1;
			t.push_back(s[j]); 
			while(j+1<s.length() && s[j+1]==s[j]){
				cnt++;
				j++;
			}
			t.push_back(cnt+'0');
		}
		s=t;
	}
	cout << s;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值