1140 Look-and-say Sequence (20分)

题目

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, …

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N ( ≤ 40 ) N(\le40) N(40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

题目大意

题目意思不太好理解,以测试点举例,

  1. 1;
  2. 1中包含1个1,所以第二趟为11;
  3. 2中包含2个1,所以第三趟为12;
  4. 3中包含1个1、1个2,所以第四趟为1121;
  5. 4中包含2个1、1个2、1个1,所以第五趟为122111;

思路

弄清楚了题意,思路自然就清楚了

代码

#include <cstdio>
#include <string>
#include <iostream>
using namespace std;

int main(){
    string d;
    int n;
    cin>>d>>n;
    for(int i=1; i<n; i++){
        string temp = "";
        char t = '-';
        int cnt = 1;
        for(int j=0; j<d.length(); j++){
            if(d[j] != t){
                temp += t;
                temp += cnt + '0';
                cnt = 0;
                t = d[j];
            }
            cnt++;
        }
        temp += t;
        temp += cnt + '0';
        d = temp.substr(2, temp.length()-2);
    }
    cout<<d<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值