1142 Maximal Clique(25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

先判断是不是clique,再判断是不是maximal

#include<cstdio>
#include<vector>
#include<fstream>
using namespace std;

int g[210][210]={0};

int main(){
	int nv, ne, m;
//	freopen("d://in.txt","r",stdin);
	scanf("%d%d", &nv, &ne);
	int u, v;
	for(int i=0; i<ne; i++){
		scanf("%d%d", &u, &v);
		g[u][v]=g[v][u]=1;
	}
	
	int k;
	scanf("%d", &m);
	for(int i=0; i<m; i++){
		vector<int> v;
		v.clear();
		int hash[210]={0};
		int x, isclique=1, ismaximal=1;
		
		scanf("%d", &k);
		for(int j=0; j<k; j++){
			scanf("%d", &x);
			v.push_back(x);
			hash[x]=1;
		}
		
		for(int j=0; j<k; j++){
			if(isclique==0) break;
			for(int j2=j+1; j2<k; j2++){
				if(g[v[j]][v[j2]]==0){
					isclique=0;
					printf("Not a Clique\n");
					break;
				}
			}
		}
		if(isclique==0) continue;
		for(int j=1; j<=nv; j++){
			if(hash[j]==0){
				for(int j2=0; j2<k; j2++){
					if(g[v[j2]][j]==0) break;
					if(j2==k-1) ismaximal=0;
				}
			}
			if(ismaximal==0){
                printf("Not Maximal\n");
                break;		
			}
		}
		if(ismaximal==1)printf("Yes\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值