暑假集训18级第一次—A - Maya Calendar

A - Maya Calendar

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

Haab: 0. pop 0

Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

Input

The date in Haab is given in the following format:
NumberOfTheDay. Month Year

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

Output

The date in Tzolkin should be in the following format:
Number NameOfTheDay Year

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

Sample Input

3
10. zac 0
0. pop 0
10. zac 1995

Sample Output

3
3 chuen 0
1 imix 0
9 cimi 2801

#include<stdio.h>
#include<string.h>
char HaabMon[19][7]={"pop","no","zip","zotz","tzec",
                     "xul","yoxkin","mol","chen","yax",
					 "zac","ceh","mac","kankin","muan",
					 "pax","koyab","cumhu","uayet"};
char TzolkinMon[20][9]={"imix","ik","akbal","kan","chicchan",
                        "cimi","manik","lamat","muluk","ok",
                       "chuen","eb","ben","ix","mem",
					   "cib","caban","eznab","canac","ahau"}; 
int main(){
	int n;
	scanf("%d",&n);
	printf("%d\n",n);
	
	while(n--){
		int day=0,mon=0;
		int hday,hyear;
		char hmon[7]={0};
		scanf("%d. %s %d",&hday,hmon,&hyear);
		 
		for(int i=0;i<20;i++)
			if(strcmp(hmon,HaabMon[i])==0) 
			{
			  mon=i;
			  break;	
			}

		day = hday+mon*20+hyear*365; 

		int tnum,tname,tyear=0;	
		
		tyear=day/260;

	    tnum=day%13+1;

		tname=day%20; 
		
		printf("%d %s %d\n",tnum,TzolkinMon[tname],tyear);
		
	}
} 

注意:
1、Tzolkin历中数字是从1开始,tnum=day%13+1
2、不需要day=day%260,直接进行运算,千万别手多啊哭了
3、二维字符串初始定义、strcmp的运用

更精简的代码

#include<stdio.h>
#include<string.h>
char HaabMon[19][7]={"pop","no","zip","zotz","tzec",
                     "xul","yoxkin","mol","chen","yax",
					 "zac","ceh","mac","kankin","muan",
					 "pax","koyab","cumhu","uayet"};
char TzolkinMon[20][9]={"imix","ik","akbal","kan","chicchan",
                        "cimi","manik","lamat","muluk","ok",
                       "chuen","eb","ben","ix","mem",
					   "cib","caban","eznab","canac","ahau"}; 
int main()
{
    int n;
    scanf("%d",&n);
    printf("%d\n",n);
    while(n--)
    {
        int day,year,days,i;
        char month[10];
        scanf("%d. %s %d",&day,month,&year);
        for(i = 0;i < 19;i++)
            if(strcmp(month,HaabMon[i])==0)
                break;
        days = year*365 + i*20 + day;
        printf("%d %s %d\n",days%13 + 1,TzolkinMon[days%20],days/260);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值