HDU 5821 Ball ( 贪心)

http://acm.hdu.edu.cn/showproblem.php?pid=5821

Problem Description

ZZX has a sequence of boxes numbered 1,2,…,n. Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1≤i≤n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,…,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.

Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],…,a[n]. Third line contains b[1],b[2],…,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.

Output
For each testcase, print “Yes” or “No” in a line.

Sample Input

5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4

Sample Output

No
No
Yes
No
Yes


题意:
归纳概括就是,一个序列,随机取一个区间[l,r]。
然后将这个区间的数随机再排列组合。
问是否能得到第二个序列。

解题思路:
构造一个序列,每个数放的是第一个序列在第二个序列中的位置。如果有相同的数,那默认从左到右增加。对于每个区间操作,直接对该构造的序列排序,这样贪心的就离结果更近一步。最后判断该序列是不是1..n。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 1100;
int arr[N], brr[N], crr[N];
bool vis[N];
int main()
{
        int  T;
        scanf("%d",&T);
        while(T--)
        {
                int n,m;
                scanf("%d%d",&n,&m);
                for(int i=1;i<=n;i++) scanf("%d",&arr[i]);
                for(int i=1;i<=n;i++) scanf("%d",&brr[i]);
                memset(vis,false,sizeof(vis));
                memset(crr,0,sizeof(crr));
                for(int i=1;i<=n;i++)
                {
                        for(int j=1;j<=n;j++)
                        {
                                if(vis[j]) continue;
                                if(brr[j]!=arr[i]) continue;
                                crr[i] = j;
                                vis[j] = true;
                                break;
                        }
                }
                while(m--)
                {
                        int l,r;
                        scanf("%d%d",&l,&r);
                        sort(crr+l,crr+r+1);
                }
                bool flag = true;
                for(int i=1;i<=n;i++) 
                {
                        if(crr[i]!=i)
                        {
                                flag = false;
                                break;
                        }
                }
                puts(flag?"Yes":"No");
        }
        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值