HDU 5821 乱搞

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
ZZX has a sequence of boxes numbered 1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1in , if the i -th box is empty then a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
题意:给你n个球的初始状态,目标状态,m个操作,每次操作可以把(l,r)区间的球取出来任意摆放,问可不可以变成最终状态。
题解:用结构体保存初始状态和目标状态的编号和数字,然后按数字大小排序,再定义新数组中每个值变为要到的下标位置,对于每次操作,sort即可,最后比较k[i]==i即可。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m,k[1005];
struct node{
    int v,p;
}a[1005],b[1005];

bool comp(node a,node b){
    if(a.v==b.v)return a.p<b.p;
    return a.v<b.v;
}

int main()
{
    int t,i,j,x,y;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++){
            scanf("%d",&a[i].v);
            a[i].p=i;
        }
        for(i=1;i<=n;i++){
            scanf("%d",&b[i].v);
            b[i].p=i;
        }
        sort(a+1,a+n+1,comp);
        sort(b+1,b+n+1,comp);
        int flag=0;
        for(i=1;i<=n;i++){
            if(a[i].v!=b[i].v){
                flag=1;
                break;
            }
            k[a[i].p]=b[i].p;
        }
        for(i=1;i<=m;i++){
            scanf("%d%d",&x,&y);
            sort(k+x,k+y+1);
        }
        for(i=1;i<=n;i++){
            if(k[i]!=i){
                flag=1;break;
            }
        }
        if(flag)printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值