hdu5821

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 208    Accepted Submission(s): 125


Problem Description
ZZX has a sequence of boxes numbered  1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For  1in , if the  i -th box is empty then  a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
 

Author

学军中学

题意:有n个A盒子里放着一些带颜色的球,又有n个B盒子里也放着n个带颜色的球,颜色用数字表示,盒子从1到n编号,然后进行m次操作,每次可以拿出 [ L - R ]的盒子里的球,然后任意放回盒子里,问最后能否使A B 盒子里球颜色一致,即相同编号盒子的球颜色相同

解:  将AB盒子按照颜色从小到大排序,颜色相同则按照原来编号由小到大排序, 然后匹配,颜色相同,则将Ai  Bi  编号用一个数组对应起来

比如最后一组样例

 编号 1  2  3  4  5                1   2   3    4   5

A       1  1  2  2  0     -- >B   2   2    1   1   0     把 A  变成 B序列嘛,就要把A1  送至 B3, A2送至B4 ,A3送至 B1 ,A4送至B2 ,A5送至 B5;

那么我们用数组  mp  表示这些" 送 "的关系  ,mp[1]=3   mp[2]=4   mp[3]=1   mp[4]=2  mp[5]=5  ,假如A B完全相同的话,那么mp[1]应该等于1,即mp[i]=i,所以我们进行[L - R ] 的操作时,就把mp[ L--R ]按照升序排序就好了,因为要使mp[ i ]=i ,那么他就是一个有序的数组啊

m次操作后,判断mp[i]是否等于 i ,然后就得出结果了,当然如果排序后颜色都不匹配肯定是No 啊

看代码:

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=1005;
struct node
{
    int id,num;
}a[maxn],b[maxn];
int mp[maxn];
bool cmp(node a,node b)
{
    if(a.num==b.num)
        return a.id<b.id;
    else
        return a.num<b.num;
}
int hk[maxn];
bool cmp2(edge a,edge b)
{
    return a.x<b.x;
}
int main()
{
    int t;
    int n,m;
    int l,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i].num);
            a[i].id=i;
        }
        sort(a+1,a+n+1,cmp);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&b[i].num);
            b[i].id=i;
        }
        sort(b+1,b+n+1,cmp);
        int flag=0;
        int tot=1;
        for(int i=1; i<=n; i++)
        {
            if(a[i].num==b[i].num)
            mp[a[i].id]=b[i].id;
            else
            flag=1;
        }
        for(int j=0; j<m; j++)
        {
            scanf("%d %d",&l,&r);
            sort(mp+l,mp+r+1);
        }
        for(int i=1; i<=n; i++)
        {
            if(mp[i]!=i)
            {
                flag=1;
                break;
            }
        }
        if(flag)
        {
            puts("No");
        }
        else
        {
            puts("Yes");
        }
    }
    return 0;
}



  

  





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值