hdu_problem_2054_A == B ?

题目大意:给两个数A和B,如果A和B相等,就输出YES,否则输出NO
该题似乎只用多考虑一种情况,例如1.00000和1

/*
*
*Problem Description
*Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
*
*
*Input
*each test case contains two numbers A and B.
*
*
*Output
*for each case, if A is equal to B, you should print "YES", or print "NO".
*
*
*Sample Input
*1 2
*2 2
*3 3
*4 3
*
*
*Sample Output
*NO
*YES
*YES
*NO
*
*
*Author
*8600 && xhd
*
*
*Source
*校庆杯Warm Up
*
*
*Recommend
*linle
*
*/
#include<iostream>
#include<string>
using namespace std;
int i;
void split(string &s) {
 if (s.find('.') == string::npos) return;
 for (i = 0; i < s.size(); ++i) {
  if (s.at(s.size() - 1 - i) != '0') {
   s.erase(s.end() - i, s.end());
   break;
  }
 }
 if (s.at(s.size() - 1) == '.') {
  s.erase(s.end() - 1, s.end());
 }
}
int main() {
 string a, b;
 while (cin >> a >> b) {
  split(a);
  split(b);
  if (a == b)
   cout << "YES" << endl;
  else
   cout << "NO" << endl;
 }
 system("pause");
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值