A + B Problem II

HDU 1002 :*A + B Problem II*

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
  I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
  The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
  For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

本题题意:
  本题意思是给你两个数要你计算两数之和。不过这题是大数加法问题。

解题思路:
  这是大数的加法问题,用字符数组来存储大数,然后转化为整形数组来计算即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <sstream>
#define max(a,b) a>b?a:b
using namespace std;
const int Max=1000;
void getDigits(int num[],char str[])///把字符串保存在int类型的数组中
{
    char digit;
    int len=strlen(str);
    for(int i=0; i<len; ++i)
    {
        digit=str[i];
        num[len-i-1]=digit-'0';///字符串倒序保存
    }
}
void add(int a[],int b[],int sum[])
{
    for(int i=0; i<Max; i++)
    {
        sum[i]=a[i]+b[i];
    }
    ///将十位以上的数字向上进位,将剩余的数字保存在自己的位置上
    for(int i=0; i<Max; i++)
    {
        sum[i+1]+=sum[i]/10;
        sum[i]=sum[i]%10;
    }
}
int main()
{
    char num1[Max],num2[Max];
    int a[Max];
    int b[Max];
    int sum[Max*2];
    int n,m;
    cin>>n;
    for(m=1; m<=n; m++)
    {
        scanf("%s%s",&num1,&num2);
        getchar();
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(sum,0,sizeof(sum));
        getDigits(a,num1);
        getDigits(b,num2);
        add(a,b,sum);
        int j=Max*2-1;0
        while(sum[j]==0)
        {
            j--;
        }
        cout<<"Case "<<m<<":"<<endl;
        cout<<num1<<" + "<<num2<<" = ";
        for(int i=j; i>=0; i--)
        {
            printf("%d",sum[i]);
        }
        printf("\n");
        if(m!=n)
            printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值