Prime Distance POJ - 2689 (素数)

5 篇文章 0 订阅
1 篇文章 0 订阅

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input
Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output
For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input
2 17
14 17
Sample Output
2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include <algorithm>
#include<cmath>
#include<vector>
#include<queue>
#define mod 1000000007
#define N 50000
using namespace std;
int prime[N];
bool sign[N];
bool state[1000050];
int cnt=0;
void init()
{
    for(int i=2;i<N;i++)
        if(!sign[i])
        {
            prime[cnt++]=i;
            for(int j=i+i;j<N;j+=i)
                sign[j]=true;
        }
}
int main()
{
    init();
    int l,r;
    while(scanf("%d%d",&l,&r)==2)
    {
        if(l==1)
            l++;
        memset(state,true,sizeof(state));
        for(int i=0;i<cnt;i++)
        {
            int L=(l-1)/prime[i]+1;
            int R=r/prime[i];
            for(int j=L;j<=R;j++)
                if(j>1)
                    state[j*prime[i]-l]=false;
        }

        int pre=-1,Max=0,Min=0x7f7f7f7f;
        int x1,y1,x2,y2;
        {
            if(state[i])
            {
                if(pre==-1){pre=i;continue;}
                if(Max<i-pre){Max=i-pre;x1=pre+l;y1=i+l;}
                if(Min>i-pre){Min=i-pre;x2=pre+l;y2=i+l;}
                pre=i;
            }
        }

        if(Max==0) cout<<"There are no adjacent primes."<<endl;
        else cout<<x2<<","<<y2<<" are closest, "<<x1<<","<<y1<<" are most distant."<<endl;
    }
    return 0;
}

这题真是见了鬼了,下面这个代码一直re,和上面相比唯一不同就是我提前把所有素数筛出来了,只是为了方便枚举,但是一直re,出错部分已经注释出来了,求大佬。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include <algorithm>
#include<cmath>
#include<vector>
#include<queue>
#define mod 1000000007
#define N 50000
using namespace std;
int prime[N];
bool sign[N];
bool state[1000050];
int cnt=0;
void init()
{
    for(int i=2;i<N;i++)
        if(!sign[i])
        {
            prime[cnt++]=i;
            for(int j=i+i;j<N;j+=i)
                sign[j]=true;
        }
}
int ans[1000000];
int k;
int main()
{
    init();
    int l,r;
    while(scanf("%d%d",&l,&r)==2)
    {
        if(l==1)
            l++;
        memset(state,true,sizeof(state));
        for(int i=0;i<cnt;i++)
        {
            int L=(l-1)/prime[i]+1;
            int R=r/prime[i];
            for(int j=L;j<=R;j++)
                if(j>1)
                    state[j*prime[i]-l]=false;
        }
        k=0;
        for(int i=l;i<=r;i++)
            if(state[i-l])
                ans[k++]=i;//检测出来就是这个把素数晒出来的这个有问题,但是真的看不出啊。。。。。
        //cout<<"haha";
        if(k<=1)
            printf("There are no adjacent primes.\n");
        else
        {
            int minn=1;
            int maxx=1;
            for(int i=2;i<k;i++)
            {
                if(ans[minn]-ans[minn-1]>ans[i]-ans[i-1])
                    minn=i;
                if(ans[maxx]-ans[maxx-1]<ans[i]-ans[i-1])
                    maxx=i;
            }
            printf("%d,%d are closest, %d,%d are most distant.\n",ans[minn-1],ans[minn],ans[maxx-1],ans[maxx]);
        }*
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值