GCD and LCM HDU - 4497 (唯一分解定理)

4 篇文章 0 订阅
2 篇文章 0 订阅

Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L?
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z.
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.
Input
First line comes an integer T (T <= 12), telling the number of test cases.
The next T lines, each contains two positive 32-bit signed integers, G and L.
It’s guaranteed that each answer will fit in a 32-bit signed integer.
Output
For each test case, print one line with the number of solutions satisfying the conditions above.
Sample Input
2
6 72
7 33
Sample Output
72
0
这个记得黑书上有唯一分解定理形式的对gcd和lcm的解释,然后就想起来了,我能做出来的题,一般都是简单题…

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<set>
#include<vector>
#define N 200005
#define mod 1000000007
using namespace std;
bool p[N];
vector<int> prime;
void init()
{
    for(int i=2;i<N;i++)
        if(!p[i])
        {
            prime.push_back(i);
            for(int j=i+i;j<N;j+=i)
                p[j]=true;
        }
}
int fac[500];
int e[500];
int cnt;
void getFac(long long x)
{
    cnt=0;
    for(int i=0;(long long)prime[i]*prime[i]<=x;i++)
    {
        if(x%prime[i]==0)
        {
            fac[cnt]=prime[i];
            e[cnt]=0;
            while(x%prime[i]==0)
            {
                x/=prime[i];
                e[cnt]++;
            }
            cnt++;
        }
    }
            if(x>1)
        {
            fac[cnt]=x;
            e[cnt]=1;
            cnt++;
        }
}
int main()
{
    int t;
    init();
    scanf("%d",&t);
    long long G,L;
    while(t--)
    {
        scanf("%lld%lld",&G,&L);
        if(L%G)
            printf("0\n");
        else
        {
            L/=G;
            getFac(L);
            long long ans=1;
            for(int i=0;i<cnt;i++)
                ans*=6*e[i];
            printf("%lld\n",ans);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值