Digital Square HDU - 4394 (数论)(DFS)

17 篇文章 0 订阅

Given an integer N,you should come up with the minimum nonnegative integer M.M meets the follow condition:
M2mod10x=n (x=0,1,2,3….)
Input
The first line has an integer T( T< = 1000), the number of test cases.
For each case, each line contains one integer N(0<= N <=10 9), indicating the given number.
Output
For each case output the answer if it exists, otherwise print “None”.
Sample Input
3
3
21
25
Sample Output
None
11
5
搜索即可

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define N 50000
#define INF 10000000000
#define mod 19940417
using namespace std;
typedef long long  ll;
ll n;
ll ans;
void dfs(ll cur,ll now)
{
    if(cur>n)
        return;
    ll c=cur*10;
    for(int i=0;i<10;i++)
    {
        ll temp=i*cur+now;
        if(temp*temp%c==n%c)
            if(temp*temp%c==n)
                ans=min(ans,temp);
            else
                dfs(c,temp);
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n==0)
        {
            printf("0\n");
            continue;
        }
        ans=INF;
        dfs(1,0);
        if(ans==INF)
            printf("None\n");
        else
            printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值