Our geometry princess XMM has stoped her study in computational geometry to concentrate on her newly opened factory. Her factory has introduced M new machines in order to process the coming N tasks. For the i-th task, the factory has to start processing it at or after day Si, process it for Pi days, and finish the task before or at day Ei. A machine can only work on one task at a time, and each task can be processed by at most one machine at a time. However, a task can be interrupted and processed on different machines on different days.
Now she wonders whether he has a feasible schedule to finish all the tasks in time. She turns to you for help.
Input
On the first line comes an integer T(T<=20), indicating the number of test cases.
You are given two integer N(N<=500) and M(M<=200) on the first line of each test case. Then on each of next N lines are three integers Pi, Si and Ei (1<=Pi, Si, Ei<=500), which have the meaning described in the description. It is guaranteed that in a feasible schedule every task that can be finished will be done before or at its end day.
Output
For each test case, print “Case x: ” first, where x is the case number. If there exists a feasible schedule to finish all the tasks, print “Yes”, otherwise print “No”.
Print a blank line after each test case.
Sample Input
2
4 3
1 3 5
1 1 4
2 3 7
3 5 9
2 2
2 1 3
1 2 2
Sample Output
Case 1: Yes
Case 2: Yes
用ek算法无限t,学了dinic好多了
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=1505;
const int maxx=520010;
int edge;
int to[maxx],flow[maxx],nex[maxx];
int head[maxn];
void addEdge(int v,int u,int cap)
{
to[edge]=u,flow[edge]=cap,nex[edge]=head[v],head[v]=edge++;
to[edge]=v,flow[edge]=0,nex[edge]=head[u],head[u]=edge++;
}
int vis[maxn];
int pre[maxn];
bool bfs(int s,int e)
{
queue<int> que;
pre[s]=-1;
memset(vis,-1,sizeof(vis));
que.push(s);
vis[s]=0;
while(!que.empty())
{
int u=que.front();
que.pop();
for(int i=head[u];~i;i=nex[i])
{
int v=to[i];
if(vis[v]==-1&&flow[i])
{
vis[v]=vis[u]+1;
if(v==e)
return true;
que.push(v);
}
}
}
return false;
}
int dfs(int s,int t,int f)
{
if(s==t||!f)
return f;
int r=0;
for(int i=head[s];~i;i=nex[i])
{
int v=to[i];
if(vis[v]==vis[s]+1&&flow[i])
{
int d=dfs(v,t,min(f,flow[i]));
if(d>0)
{
flow[i]-=d;
flow[i^1]+=d;
r+=d;
f-=d;
if(!f)
break;
}
}
}
if(!r)
vis[s]=INF;
return r;
}
int maxFlow(int s ,int e)
{
int ans=0;
while(bfs(s,e))
ans+=dfs(s,e,INF);
return ans;
}
void init()
{
memset(head,-1,sizeof(head));
edge=0;
}
int main()
{
int t;
scanf("%d",&t);
int n,m;
int p,s,e;
int top=-1;
int cal=1;
while(t--)
{
scanf("%d%d",&n,&m);
int sum=0;
init();
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&p,&s,&e);
sum+=p;
top=max(top,e);
addEdge(0,i,p);
for(int j=s;j<=e;j++)
addEdge(i,n+j,1);
}
for(int i=1;i<=top;i++)
addEdge(n+i,top+n+1,m);
if(sum==maxFlow(0,top+n+1))
printf("Case %d: Yes\n\n",cal++);
else
printf("Case %d: No\n\n",cal++);
}
return 0;
}