(pat)A1020. Tree Traversals

16 篇文章 0 订阅
13 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

和之前的问题差不多,就是变成了后序遍历而已

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int post[35];
int in[35];
struct node
{
    int val;
    node* l;
    node* r;
};
node* root;
node* findd(int l,int r,int L,int R)
{
    if(l>r)
        return NULL;
    node* p=new node;
    p->val=post[R];
    int mid;
    for(mid=l;mid<=r;mid++)
        if(in[mid]==post[R])
            break;
    //printf("%d\n",mid);
    p->r=findd(mid+1,r,mid-r+R,R-1);
    p->l=findd(l,mid-1,L,L-l+mid-1);
    return p;
}
int layer[35];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",post+i);
    for(int i=0;i<n;i++)
        scanf("%d",in+i);
    for(int i=0;i<n;i++)
    if(n==1)
    {
        printf("%d",post[0]);
        return 0;
    }
    root=findd(0,n-1,0,n-1);
    queue<node*> que;
    que.push(root);
    int num=0;
    while(!que.empty())
    {
        node *temp=que.front();
        que.pop();
        layer[num++]=temp->val;
        if(temp->l!=NULL)
            que.push(temp->l);
        if(temp->r!=NULL)
            que.push(temp->r);
    }
    for(int i=0;i<n-1;i++)
        printf("%d ",layer[i]);
    printf("%d",layer[n-1]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值