(pat)A1086. Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

鹏神说建树的题都是模拟的题,好像是这么回事TT

#include<iostream>
#include<cstdio>
#include<stack>

using namespace std;
struct node
{
    int data;
    node* l;
    node* r;
};
node* newNode(int v)
{
    node* p=new node;
    p->data=v;
    p->l=p->r=NULL;
    return p;
}
int a[33];
int num=0;
void post(node* root)
{
    if(root==NULL)
        return;
    post(root->l);
    post(root->r);
    a[num++]=root->data;
}
int main()
{
    int n;
    scanf("%d",&n);
    stack<node*> st;
    node* temp;
    node* root;
    n*=2;
    string str;
    int x;
    cin>>str>>x;
    root=newNode(x);
    temp=root;
    st.push(temp);
    for(int i=1;i<n;i++)
    {
        cin>>str;
        if(str.compare("Push")==0)
        {
            cin>>x;
            if(temp->l==NULL)
            {
                temp->l=newNode(x);
                st.push(temp->l);
                temp=temp->l;
            }
            else
            {
                temp->r=newNode(x);
                st.push(temp->r);
                temp=temp->r;
            }
        }
        else
        {
            temp=st.top();
            st.pop();
        }
    }
    //cout<<"haha";
    post(root);
    for(int i=0;i<num-1;i++)
        printf("%d ",a[i]);
    printf("%d\n",a[num-1]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值