Pagodas HDU - 5512 (数论)

4 篇文章 0 订阅

n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1≤a≠b≤n) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
Input
The first line contains an integer t(1t500) t ( 1 ≤ t ≤ 500 ) which is the number of test cases.
For each test case, the first line provides the positive integer n(2n20000) n ( 2 ≤ n ≤ 20000 ) and two different integers a and b.
Output
For each test case, output the winner (Yuwgna"orIaka") ( ‘ ‘ Y u w g n a " o r ‘ ‘ I a k a " ) . Both of them will make the best possible decision each time.
Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12
Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

讲道理他给这么多样例,就是以找规律为导向的。但是这种规律能找出来我服!我当然还是推导了,用一点数论的知识就可以证明。
思路:
假设没有范围限制,只是给两个点,那么接来下能够扩展的点有什么什么特点?
设:初始点 ab a 和 b ,那么下一个点的产生是 a+b a + b ab a − b ,那么下一个呢?可能是 2a+b 2 a + b 2a+b 2 a + b 等等,其实很显然了,
所能生产点的特点就是

xa+yb x a + y b

假设 num=xa+yb n u m = x a + y b ,那么num有什么要去呢,这个是有定理的,只有 gcd(a,b)num g c d ( a , b ) 能 整 除 n u m ,(不知道的赶快补)那么这个num才能被表示。
那么有多少个只有的num?
total=ngcd(a,b)() t o t a l = n g c d ( a , b ) ( 向 下 取 整 )

如果数量是偶数,先手输反之先手赢…
签到题难度。

#include <iostream>
#include <vector>
#include <cmath>
#include <cstdio>
#define maxx 20050
using namespace std;
int t;
int n,a,b;
int gcd(int x,int y)
{
    while(y^=x^=y^=x%=y);
    return x;
}
int k;
int main()
{
    cin>>t;
    int cal=1;
    while(t--)
    {
        scanf("%d%d%d",&n,&a,&b);
        k=gcd(a,b);
        int left=n/k;
        printf("Case #%d: ",cal++);
        if(left&1)
            cout<<"Yuwgna"<<endl;
        else
            cout<<"Iaka"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值