Intervals POJ - 1201(差分约束)(最短路)

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.
Write a program that:
reads the number of intervals, their end points and integers c1, …, cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,…,n,
writes the answer to the standard output.
Input
The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.
Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,…,n.
Sample Input
5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1
Sample Output
6

差分约束第一题,就是转换为最短的模型来做的。
下次详细讲解一下。
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxx 50005
#define INF 0x7f7f7f7f
using namespace std;
int head[maxx];
int to[maxx<<2],w[maxx<<2],_next[maxx<<2];
int cnt=0;
int n;
void addEdge(int x,int y,int c)
{
    to[++cnt]=y,w[cnt]=c,_next[cnt]=head[x],head[x]=cnt;
}
void init()
{
    memset(head,0,sizeof(head));
    cnt=0;
}
int L=maxx,R=0;
char inQ[maxx];
int dis[maxx];
int spfa()
{
    memset(dis,-INF,sizeof(dis));
    queue<int> que;
    que.push(L);
    inQ[L]=true;
    dis[L]=0;
    while(que.size())
    {
        int now=que.front();que.pop();
        inQ[now]=false;
        for(int i=head[now];i;i=_next[i])
        {
            int v=to[i];
            int d=w[i];
            if(dis[v]<dis[now]+d)
            {
                dis[v]=dis[now]+d;
                if(!inQ[v])
                {
                    inQ[v]=true;
                    que.push(v);
                }
            }
        }

    }
    return dis[R];
}
int main()
{
    cin>>n;
    int a,b,c;
    init();
    for(int i=0;i<n;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        addEdge(a,b+1,c);
        L=min(L,a);
        R=max(R,b);
    }
    R++;
    for(int i=L;i<R;i++)
        addEdge(i,i+1,0),addEdge(i+1,i,-1);
    cout<<spfa()<<endl;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值