Minimum Inversion Number HDU - 1394(权值线段树)

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16

额,不就是线段树代替了树状数组了么。。。。不过正常来讲似乎都是用分治来做吧。。。为了学习所谓的权值线段树。。。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxx 5005
using namespace std;
int c[maxx<<2];
void update(int st,int l,int r,int x)
{
    if(l==r&&l==x)
    {
        c[st]++;
        return;
    }
    int mid=(l+r)>>1;
    if(x<=mid)update(st<<1,l,mid,x);
    else update(st<<1|1,mid+1,r,x);
    c[st]=c[st<<1]+c[st<<1|1];
}
int query(int st,int l,int r,int L,int R)
{
    if(L<=l&&r<=R)
        return c[st];
    int mid=(l+r)>>1;
    int ans=0;
    if(L<=mid)ans+=query(st<<1,l,mid,L,R);
    if(R>mid)ans+=query(st<<1|1,mid+1,r,L,R);
    return ans;
}
int n;
int a[5005];
int main()
{
    while(scanf("%d",&n)==1)
    {
        int now=0;
        int x;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            a[i]=x+1;
            now+=query(1,1,n,a[i]+1,n);
            update(1,1,n,a[i]);
        }
        int ans=now;
        for(int i=1;i<=n;i++)
        {
            now-=a[i]-1;
            now+=n-a[i];
            ans=min(ans,now);
        }
        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值