hdu 2586 How far away ? (tarjan离线LCA算法)

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

题意:给出n-1条边构成一棵树,m次询问,求两点间距离。

思路:求出每个每个点到根节点的权,两个房子的LCA,求出两个房子到LCA的值相加就是答案。

#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 40010
using namespace std;
struct path
{
    int to,nextt,w;
} A[M*2],B[M*2];
struct node
{
    int x,y,lca;
} C[M*2];
int t,x,y,n,m,w,tot,root;
int headA[M],headB[M],in[M],d[M],fa[M];
void init()
{
    tot=0;
    memset(headA,-1,sizeof(headA));
    memset(headB,-1,sizeof(headB));
    memset(fa,0,sizeof(fa));
    memset(in,0,sizeof(in));
}
void dfs(int u,int pre,int k)
{
    int tem;
    d[u]=k;
    for(int i=headA[u]; i!=-1; i=A[i].nextt)
    {
        tem=A[i].to;
        if(tem==pre) continue;
        dfs(tem,u,k+A[i].w);
    }
}
void addA(int x,int y,int w)
{
    A[tot].to=y;
    A[tot].w=w;
    A[tot].nextt=headA[x];
    headA[x]=tot++;
}
void addB(int x,int y,int k)
{
    B[tot].to=y;
    B[tot].w=k;
    B[tot].nextt=headB[x];
    headB[x]=tot++;
}
int Find(int x)
{
    if(fa[x]!=x) return fa[x]=Find(fa[x]);
    return fa[x];
}
void tarjan(int u,int pre)
{
    int tem;
    fa[u]=u;
    for(int i=headA[u]; i!=-1; i=A[i].nextt)
    {
        tem=A[i].to;
        if(tem==pre) continue;
        tarjan(tem,u);
        fa[tem]=u;
    }
    for(int i=headB[u]; i!=-1; i=B[i].nextt)
    {        tem=B[i].to;
        if(fa[tem])
            C[B[i].w].lca=Find(tem);
    }

}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d%d",&n,&m);
        for(int i=1; i<n; i++)
        {
            scanf("%d%d%d",&x,&y,&w);
            addA(x,y,w);
            addA(y,x,w);
            in[y]++;
            in[x]++;
        }
        dfs(1,-1,0);
        tot=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&x,&y);
            addB(x,y,i);
            addB(y,x,i);
            C[i].x=x;
            C[i].y=y;
        }
        tarjan(1,-1);
        int ans;
        for(int i=1; i<=m; i++)
        {
            ans=d[C[i].x]+d[C[i].y]-2*d[C[i].lca];
            printf("%d\n",ans);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值