HDU 3367 Pseudoforest(kruskal最大生成树变形)

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3019    Accepted Submission(s): 1194


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
  
  
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
  
  
3 5
 
一开始以为是判断如果两个的父节点相等,并且之前没有出现过这种情况就可以相加,然后之后就再也不用判断两个点的父节点的相等的这个情况,结果wa,看了题解,原来这种投机取钱的方法是错的,如果有两个子集但是他们是两个环就不可以合并,这点需要判断,所以需要详细的判断当前的子集是否有环,这里用chun[]这个数组来判断就好了。
#include <stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int bin[100010],flag;
long long sum;
struct node{
	int s,e,w;
}a[100001];
int judge[100001];
int findx(int x)
{
	return bin[x]==x?x:bin[x]=findx(bin[x]);
}
int merge(int a,int b,int c)
{
	int fx=findx(a);
	int fy=findx(b);
	if(fx!=fy)
	{
		if(judge[fx]&&judge[fy])
		return 0;
		bin[fy]=fx;
		sum+=c;
		if(judge[fx]||judge[fy])
		judge[fx]=1;
	}
	else if(fx==fy&&!judge[fx])
	{
		judge[fx]=1;
		sum+=c;
	}
}
int cmp(node a,node b)
{
	return a.w>b.w;
}
int main(int argc, char *argv[])
{
	int n,m;
	while(scanf("%d %d",&n,&m),m+n)
	{
		int i;
		memset(judge,0,sizeof(judge));
		for(i=0;i<n;i++)
		{
			bin[i]=i;
		}
		for(i=0;i<m;i++)
		{
			scanf("%d %d %d",&a[i].s,&a[i].e,&a[i].w);
		}
		sort(a,a+m,cmp);
		sum=0;
		for(i=0;i<m;i++)
		{
			merge(a[i].s,a[i].e,a[i].w);
		}
		printf("%lld\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值