hdu 3555 bomb(数位dp)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 20583    Accepted Submission(s): 7705


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 
#include <stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
__int64 dp[50][2];
__int64 a[50];
__int64 dfs(__int64 pos,__int64 pre,__int64 sta,bool limit)
{
	if(pos==-1)
	{
		return 1;
	}
	if(dp[pos][sta]!=-1&&!limit)
	return dp[pos][sta];
	
	__int64 up=limit?a[pos]:9;
	__int64 i,sum=0;
	for(i=0;i<=up;i++)
	{
		if(pre==4&&i==9)
		continue;
		sum+=dfs(pos-1,i,i==4,limit&&i==up);
	} 
	if(!limit)
	dp[pos][sta]=sum;
	return sum;
}
__int64 solve(__int64 x)
{
	__int64 cnt=0;
	while(x)
	{
		a[cnt++]=x%10;
		x=x/10;
	}
	return dfs(cnt-1,-1,0,1);
}
int main(int argc, char *argv[])
{
	int t;
	scanf("%d",&t);
	memset(dp,-1,sizeof(dp));
	while(t--)
	{
		__int64 x;
		scanf("%I64d",&x);
		printf("%I64d\n",x+1-solve(x));//0-x的数为 x+1  solve(x)为所有统计的非满足 49 的数
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值