hdu 3555 Bomb 数位dp

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15


        
  
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.
思路:数位dp,dp[i][j][k],i表示第i位,j表示前一位的数,k表示前边是否出现过49
 
 
ac代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int num[20];
long long dp[20][10][2];
long long dfs(int len,int pre,int state,int limit)
{
    if(len<0)
    return state;
    if(!limit&&dp[len][pre][state]!=-1)
    return dp[len][pre][state];
    int fp=limit?num[len]:9;
    long long ret=0;
    for(int i=0;i<=fp;i++)
    ret+=dfs(len-1,i,state||(pre==4&&i==9),limit&&i==fp);
    if(!limit)
    dp[len][pre][state]=ret;
    return ret;
}
long long get_num(long long x)
{
    int len=0;
    while(x)
    {
        num[len++]=x%10;
        x=x/10;
    }
    return dfs(len-1,0,0,1);
}
int main()
{
    long long n,m;
    memset(dp,-1,sizeof(dp));
    int t;
    cin>>t;
    while(t--)
    {
       cin>>n;
       long long ans=get_num(n);
       cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值