HDU 3555 Bomb 数位Dp

D - Bomb
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 
 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 
 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input

     
     
3 1 50 500
 

Sample Output

     
     
0 1 15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

判断是否子串是否含有49

按位dp即可 需要判断前面位数的3种状态

ACcode

#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
using namespace std;
ll dp[25][3];///第二个参数表示 2-》》含有49、1--》》 不含有49但前位是4   0--》》其他
int date[25];
ll dfs(int pos,int flag,bool limit){
    if(!pos)return flag==2;
    if(!limit&&dp[pos][flag]!=-1)
        return dp[pos][flag];
    ll ans=0;
    int ed=limit?date[pos]:9;
    for(int i=0;i<=ed;++i){
        int tmp=flag;
        if(flag==1&&i==9)
            tmp=2;
        else if(flag==0&&i==4)
            tmp=1;
        else if(flag==1&&i!=4&&i!=9)
            tmp=0;
        ans+=dfs(pos-1,tmp,limit&&i==ed);
    }
    return limit?ans:dp[pos][flag]=ans;
}
void doit(){
    ll n;
    scanf("%I64d",&n);
    int len=0;
    while(n){
        date[++len]=n%10;
        n/=10;
    }
    printf("%I64d\n",dfs(len,0,1));
}
int main(){
    int loop;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&loop);
    while(loop--)doit();
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值