HDU 1142 A Walk Through the Forest(dijkstra+记忆化搜索)

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9518    Accepted Submission(s): 3510


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
 
     
5 61 3 21 4 23 4 31 5 124 2 345 2 247 81 3 11 4 13 7 17 4 17 5 16 7 15 2 16 2 10
 
Sample Output
 
     
24
 

Source
 
题意要求找出所有的最短路的条数
现用dijkstra算法把所有的点松弛,因为是找0-2的最短路那么需要以二到起点到所有的其他的点最短路都求出来,
然后记忆化搜索,dp[k]表示当前的k节点之后有多少条路,如果遇到可以直接调用
#include <stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
int n,m;
int visit[1001];
int minload[1001];
int map[1001][1001];
int dp[1001];
int dfs(int x)
{
    if(dp[x]!=-1)//储存这个点有多少路这样的话到这个点就可以直接调用了 
    {
        return dp[x];
    }
    if(x==2)
    {
        return 1;
    }
    int i;
    int sum=0;
    for(i=1;i<=n;i++)
    {
        if(map[x][i]!=INF&&minload[x]>minload[i])
        {
            sum+=dfs(i);    
        }
    }
    dp[x]=sum;
    return  dp[x]; 
}
int main(int argc, char *argv[])
{
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        int i,j;
        for(i=0;i<1001;i++)
        {
            visit[i]=1;
            dp[i]=-1;
            minload[i]=INF;
            for(j=0;j<1001;j++)
            {
                map[i][j]=INF;    
            }
        }
        int a,b,dis;
        while(m--)
        {
            scanf("%d %d %d",&a,&b,&dis);
            map[a][b]=map[b][a]=min(map[a][b],dis);
        }
        int sta=2;
        minload[2]=0;
        visit[2]=0;
        for(i=1;i<=n;i++)
        {
            int min1=INF;
            int next;
            for(j=1;j<=n;j++)
            {
                minload[j]=min(minload[j],map[sta][j]+minload[sta]);
                if(min1>minload[j]&&visit[j])
                {
                    min1=minload[j];
                    next=j;
                }        
            }
            if(min1==INF)
            {
                break;
            }
            sta=next;
            visit[sta]=0;
        }
    //    printf("%d\n",minload[1]);
        printf("%d\n",dfs(1));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值