A Walk Through the Forest HDU - 1142

                           A Walk Through the Forest HDU - 1142

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.  
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.  
InputInput contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.  
OutputFor each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647  
Sample Input
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0
Sample Output
2
4

题目大意:我们要从1到达2 问我们有多少种走法。但是我们不能越走越远,就是我们选择走这条路,只能距离2这个点越来越近。
思路:我们先dijsktra 点2到所有点的最短路,这样就能判断我们走的是不是距离2越来越近。然后dfs搜索,符合题意的路径,当我们搜索到点2 即可返回。

直接上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
#define P pair<int ,int >
const int maxn=1000+10;
const int INF = 0x3f3f3f3f;
int Lext[maxn],Next[maxn*200],To[maxn*200],Len[maxn*200],dis[maxn],cost[maxn];
int cnt;
void add(int u,int v,int w)
{
    Next[++cnt]=Lext[u];
    Lext[u]=cnt;
    To[cnt]=v;
    Len[cnt]=w;
}
void init()
{
    cnt=0;
    memset(Lext,-1,sizeof(Lext));
    memset(dis,INF,sizeof(dis));
    memset(cost,0,sizeof(cost));
}
void dij(int st)
{
    dis[st]=0;
    priority_queue<P,vector<P >, greater<P > >q;
    q.push(P(0,st));
    while(!q.empty())
    {
        P temp=q.top();
        q.pop();
        int x=temp.second;
        for(int i=Lext[x]; i!=-1; i=Next[i])
        {
            int y=To[i];
            int d=Len[i];
            if(dis[y]>dis[x]+d)
            {
                dis[y]=dis[x]+d;
                q.push(P(dis[y],y));
            }
        }
    }
}
int dfs(int st)
{
    //cost数组用来存一共有多少走法
    if(st==2) return 1;
    if(cost[st]) return cost[st];
    for(int i=Lext[st]; i!=-1; i=Next[i])
    {
        int y=To[i];
        if(dis[y]<dis[st])
            cost[st]+=dfs(y);
    }
    return cost[st];
}
int main()
{
    int n,m,u,v,w;
    while(scanf("%d",&n),n)
    {
        init();
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        dij(2);
        cout<<dfs(1)<<endl;
    }
}
学习算法需要重复记忆,时隔一段时间没敲Dij了 理解了还是敲的蛮快的  继续水题(逃
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值