POJ - 2318 -- TOYS【叉积+暴力 or 叉积+二分】

TOYS
Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
在这里插入图片描述
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

题意

给你一个正方形,再给出n个分界线,然后给出m个点,求每个分区落了多少个点。只能包含再内部,边界线以及以外的都不算。

暴力解法

我们先存下这些分界线,然后输入每个点都去遍历每条分界线,利用叉积的定义,我们能求出此点在那个分区,即点A在前面一个分界线的逆时针方向,A在后面一个分界线的顺时针方向

AC代码
#include<cstdio>
#include<utility> 
#include<algorithm>
#include<cmath>
using namespace std;
const double eps = 1e-6;
const int maxn = 5e3+5;
struct Point{
	double x,y;
	Point(double a = 0, double b = 0){x=a,y=b;}
};
typedef Point Vector;

pair<Point,Point> limit[maxn];
int ans[maxn];
int dcmp(double a,double b){ 
	if(fabs(a-b) < eps){
		return 0;
	}
	return a>b ? 1 : -1;
}
Vector operator - (Point A, Point B){
	return Vector(A.x-B.x, A.y-B.y);
}
double Cross(Vector A,Vector B){
	return A.x*B.y - A.y*B.x;
}
int main(){
	int n,m;
	double x1,y1,x2,y2,ui,li;
	while(scanf("%d",&n),n!=0){
		scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
		for(int i=0;i<=n;i++)	ans[i]=0;
		limit[0]=make_pair(Point(x1,y1),Point(x1,y2));
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&ui,&li);
			limit[i]=make_pair(Point(ui,y1),Point(li,y2));
		}
		limit[n+1]=make_pair(Point(x2,y1),Point(x2,y2));
		double x,y;
		while(m--){
			scanf("%lf%lf",&x,&y);
			for(int i=0;i<=n+1;i++){
				if(Cross(limit[i].first-limit[i].second, limit[i].first-Point(x,y) )>0 && 
				Cross(limit[i+1].first-limit[i+1].second, limit[i+1].first-Point(x,y) )<0 )
					ans[i]++;
			}
		}
		for(int i=0;i<=n;i++)
			printf("%d: %d\n",i,ans[i]);
		puts(""); 
	 }
	 return 0;
}
二分解法

首先,本题给我们的分界线都是从小到大给出的,我们来想一下A点如果在某个分区里面,则一定满足,A在所有左边分解线的逆时针方向,在所有右边分解线的顺时针方向,则可以用二分的思想来解决

AC代码
/**
	思路:给出了分界线的点,我们先把分界线向量求出,然后枚举每个点是否在两个连续的向量中间即可
	用叉积来判断。 
**/
#include<cstdio>
#include<utility> 
#include<algorithm>
#include<cmath>
using namespace std;
const double eps = 1e-6;
const int maxn = 5e3+5;
struct Point{
	double x,y;
	Point(double a = 0, double b = 0){x=a,y=b;}
};
typedef Point Vector;

pair<Point,Point> limit[maxn];
int ans[maxn];
int dcmp(double a,double b){ 
	if(fabs(a-b) < eps){
		return 0;
	}
	return a>b ? 1 : -1;
}
Vector operator - (Point A, Point B){
	return Vector(A.x-B.x, A.y-B.y);
}
double Cross(Vector A,Vector B){
	return A.x*B.y - A.y*B.x;
}
bool cheak(int x,int y,int m){
	if(Cross(Point(x,y)-limit[m].first, limit[m].second-limit[m].first) > 0)
		return true;
	return false;
}
int main(){
	int n,m;
	double x1,y1,x2,y2,ui,li;
	while(scanf("%d",&n),n!=0){
		scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
		for(int i=0;i<=n;i++)	ans[i]=0;
		limit[0]=make_pair(Point(x1,y1),Point(x1,y2));
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&ui,&li);
			limit[i]=make_pair(Point(ui,y1),Point(li,y2));
		}
		limit[n+1]=make_pair(Point(x2,y1),Point(x2,y2));
		double x,y;
		while(m--){
			scanf("%lf%lf",&x,&y);
			int l=0,r=n+1;
			while(r-l>1){
				int mid=(l+r)>>1;
				if(cheak(x,y,mid))	r=mid;
				else l=mid;
			}
			ans[r-1]++;
		}
		for(int i=0;i<=n;i++)
			printf("%d: %d\n",i,ans[i]);
		puts(""); 
	 }
	 return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星空皓月

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值