POJ2769 Reduced ID Numbers[同余]


Reduced ID Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9813 Accepted: 3923

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8


题意:

找到与G个数取余的结果都不相同的数


从1开始循环开始,因为一定是有结果的,所以循环可以不设置停止条件,找到结果之后,终止循环即可

每次更新mark数组的时候,只需要吧0到i-1的值归零,因为余数只会在0到i-1的范围内.


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
const int N=310;
const int M=1e6;
int num[N];
bool mark[M];
int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        int n;
        scanf("%d",&n);
        for (int i=0 ; i<n ; i++)
            scanf("%d",&num[i]);
        int ans=1;
        for (int i=1 ; ; i++)
        {
            for (int j=0 ; j<i ; j++)//余数只会取到比i小的数
                mark[j]=0;
            bool flag=0;
            for (int j=0 ; j<n ; j++)
            {
                if (!mark[num[j]%i])
                    mark[num[j]%i]=1;
                else                     
                {
                    flag=1;
                    break;
                }
            }
            if (!flag)
            {
                ans=i;
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}













  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值