1004 Counting Leaves

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1


题型分类:树、层序遍历

题目大意:输出每层叶节点的数目。

解题思路:定义结点的结构体Node,采用STL模板的queue来进行层序遍历,遍历过程中将孩子结点的层数+1,leaves数组用来存储每层叶节点的数目。


#include <cstdio>
#include <queue>
#include <vector> 

using namespace std;

const int maxn = 110;

typedef struct {
	int layer;
	vector<int> child;
}Node;

int leaves[maxn], maxLayer = -1;
Node node[maxn];

void levelOrder(int st);

int main(int argc, char** argv) {
	int N, M;
	scanf("%d %d", &N, &M);
	for(int i = 0; i < M; i++){
		int father, K, tempChild;
		scanf("%d %d", &father, &K);
		for(int j = 0; j < K; j++){
			scanf("%d", &tempChild);
			node[father].child.push_back(tempChild);
		}
	}
	levelOrder(1);
	for(int i = 1; i <= maxLayer; i++){
		if(i != 1) printf(" ");
		printf("%d", leaves[i]);
	}
	return 0;
}

void levelOrder(int st){
	queue<int> q;
	q.push(st);
	node[st].layer = 1;
	while(!q.empty()){
		int now = q.front();
		q.pop();
		if(node[now].child.empty()){
			leaves[node[now].layer]++; //这一层的叶结点数目+1 
			if(node[now].layer > maxLayer){ //最大层的节点一定为叶结点 
				maxLayer = node[now].layer;
			}
		}
		for(int i = 0; i < node[now].child.size(); i++){
			q.push(node[now].child[i]);
			node[node[now].child[i]].layer = node[now].layer + 1; //孩子结点的层数+1 
		}
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值