1032 Sharing

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10^​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1


题型分类:静态链表

题目大意:给出两个单词的开头结点,找出两个单词的公共后缀,找到后输出公共后缀的开始位置,找不到输出-1。

解题思路:用visited来表示结点有没有访问过,第二个单词第一次访问到visited == true的结点时,表示找到公共后缀的起始位置。


#include <cstdio> 

const int maxn = 100010;

typedef struct Node{
	char data;
	int next;
	bool visited;
	Node(){
		visited = false;
	}
}Node;

Node node[maxn];

int main(int argc, char** argv) {
	int word1, word2, N;
	scanf("%d %d %d", &word1, &word2, &N);
	for(int i = 0; i < N; i++){
		int address;
		scanf("%d ", &address);
		scanf("%c %d", &node[address].data, &node[address].next); 
	}
	int p = word1;
	while(p != -1){
		node[p].visited = true;
		p = node[p].next;
	}
	p = word2;
	while(p != -1 && node[p].visited == false){ //找到末尾或者找到相同后缀退出 
		p = node[p].next;
	}
	if(p != -1) printf("%05d", p);
	else printf("-1");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值