1017 Queueing at Bank

1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2


题型分类:快乐模拟

题目大意:银行的营业时间为8:00 - 17:00,给定K个窗口,顾客依次在线后等待,计算被服务到的(17:00以后的顾客没有被服务到)顾客的平均等待时间。

解题思路:注意几个细节就好:①每个顾客的服务时间不超过1小时。②银行8:00以后才开始营业。③17:00以后的顾客不会被服务到,不计入数据。


#include <cstdio>
#include <algorithm>

using namespace std;

const int maxCus = 10010;
const int maxWin = 110;
const int INF = 0x3f3f3f3f;

typedef struct {
	int arriveTime;
	int processTime;
}customer;

customer cus[maxCus];
int window[maxWin];

int convertToSecond(int hh, int mm, int ss);
bool cmp(customer a, customer b);

int main(int argc, char** argv) {
	int N, K;
	int stTime = convertToSecond(8, 0, 0), edTime = convertToSecond(17, 0, 0);
	scanf("%d %d", &N, &K);
	for(int i = 0; i < N; i++){
		int hh, mm, ss;
		scanf("%d:%d:%d %d", &hh, &mm, &ss, &cus[i].processTime);
		cus[i].processTime = cus[i].processTime > 60 ? 60 * 60 : cus[i].processTime * 60; //一个客户最多服务1H 
		cus[i].arriveTime = convertToSecond(hh, mm, ss);
	}
	sort(cus, cus + N, cmp);
	int totalWait = 0;
	for(int i = 0; i < K; i++){
		window[i] = stTime;
	}
	int cnt = 0;
	for(int i = 0; i < N; i++){
		if(cus[i].arriveTime > edTime) break; 
		int winNum = -1, min = INF;
		for(int j = 0; j < K; j++){
			if(window[j] < min){
				winNum = j;
				min = window[j];
			}
		}
		if(window[winNum] < cus[i].arriveTime){ //此时表示顾客不用等待 
			window[winNum] = cus[i].arriveTime + cus[i].processTime;
		}else{
			totalWait += window[winNum] - cus[i].arriveTime;
			window[winNum] = window[winNum] + cus[i].processTime;
		}
		cnt++;
	}	
	printf("%.1f", (double)totalWait / 60 / cnt);
	
	return 0;
}

int convertToSecond(int hh, int mm, int ss){
	return hh * 3600 + mm * 60 + ss; 
}

bool cmp(customer a, customer b){
	return a.arriveTime < b.arriveTime;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值