1018 Public Bike Management

1018 Public Bike Management (30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0


题型分类:图、Dijkstra

题目大意:对车辆进行调度,使目标站点和途径站点的车辆数目达到完美状态(最大容量的一半)。

解题思路:对于多种比较条件的题目,可以套用模板:先用Dijkstra存下第一条件(本题中为最短路径),再用DFS找到第二条件下(本题中为带去的车辆最少,如果带去的车辆相等,再比较带回的车辆最少)的最优解。


#include <cstdio>
#include <vector>
#include <algorithm>
#include <cmath>

using namespace std;

const int maxn = 510;
const int INF = 0x3f3f3f3f;

int G[maxn][maxn];
bool visited[maxn];
int d[maxn], weight[maxn];
int Cmax, N, Sp, M;
vector<int> pre[maxn];
vector<int> path, tempPath;
int send = INF, remain;

void Dijkstra(int s);
void DFS(int v);

int main(int argc, char** argv) {
	scanf("%d %d %d %d", &Cmax, &N, &Sp, &M);
	for(int i = 1; i <= N; i++) {
		scanf("%d", &weight[i]);
		weight[i] -= Cmax/2; //表示距离完美状态还差几辆车
	}
	fill(G[0], G[0] + maxn * maxn, INF);
	for(int i = 0; i < M; i++) {
		int c1, c2, len;
		scanf("%d %d %d", &c1, &c2, &len);
		G[c1][c2] = G[c2][c1] = len;
	}
	Dijkstra(0);
	DFS(Sp);
	printf("%d ", send);
	for(int i = path.size() - 1; i >= 0; i--) {
		printf("%d", path[i]);
		if(i != 0) printf("->");
	}
	printf(" %d", remain);
	return 0;
}

void Dijkstra(int s) {
	fill(d, d + maxn, INF);
	d[s] = 0;
	for(int i = 0; i <= N; i++) { //注意这里要取到N
		int u = -1, min = INF;
		for(int j = 0; j <= N; j++) {
			if(visited[j] == false && d[j] < min) {
				min = d[j];
				u = j;
			}
		}
		if(u == -1) return;
		visited[u] = true;
		for(int v = 0; v <= N; v++) {
			if(visited[v] == false && G[u][v] != INF) {
				if(d[u] + G[u][v] < d[v]) {
					d[v] = d[u] + G[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				} else if(d[u] + G[u][v] == d[v]) {
					pre[v].push_back(u);
				}
			}
		}
	}
}

void DFS(int v) {
	tempPath.push_back(v);
	if(v == 0) { //0表示PBMC
		int tempSend = 0, tempRemain = 0;
		for(int i = tempPath.size() - 1; i >= 0; i--) {
			int id = tempPath[i], num = abs(weight[id]); //id表示站点的序号,num表示站点缺少或者多余自行车的数量 
			if(weight[id] < 0) { //路途经过的车辆小于最大容量的一半,需要补充 
				if(tempRemain > num) { //现在的车辆够用 
					tempRemain -= num;
				} else { //现在拥有车车辆不够用,需要从PBMC调用 
					tempSend += num - tempRemain;
					tempRemain = 0;
				}
			} else { //车辆多余,需要带走 
				tempRemain += num;
			}
		}
		if(tempSend < send) { //如果需要携带的车辆比较少,更新最终路径 
			path = tempPath;
			send = tempSend;
			remain = tempRemain;
		} else if(tempSend == send && tempRemain < remain) { //携带车辆相等,比较带回的车辆数目 
			path = tempPath;
			remain = tempRemain;
		}
		tempPath.pop_back();
		return;
	}
	for(int i = 0; i < pre[v].size(); i++) {
		DFS(pre[v][i]);
	}
	tempPath.pop_back();
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值