1019 General Palindromic Number

1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1


题型分类:字符串处理

题目大意:从前往后和从后往前相同的串叫做回文串。给定一个数,确认这个数在新的进制b下是否也是回文串。

解题思路:要注意有可能新的进制是大于10的,所以需要用数组进行存储每一位的值


#include <cstdio>

using namespace std;

int str[35]; //int转换成2进制数最多是32位,int最大能表示2×10^9 
int len = 0;

void convertTobRadix(int N, int b);
bool isPalin(int *str);

int main(int argc, char** argv) {
	int N, b;
	scanf("%d %d", &N, &b);
	convertTobRadix(N, b);
	if(isPalin(str)) printf("Yes\n");
	else printf("No\n");
	for(int i = len - 1; i >= 0; i--){
		printf("%d", str[i]);
		if(i != 0) printf(" ");
	}
	return 0;
}

void convertTobRadix(int N, int b){
	do{
		str[len++] = N % b;
		N /= b;
	}while(N);
}

bool isPalin(int *str){
	for(int i = 0; i <= len / 2; i++){
		if(str[i] != str[len - i - 1]){
			return false;
		}
	}
	return true;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值