IPV4,V6实验

1.配置v4,v6地址

 

 

 


 

 

 

 

 

 

 

 2.OSPF宣告

[r3-ospfv3-1]router-id 3.3.3.3
[r3-GigabitEthernet0/0/1]ospfv3 1 area  0
[r4-ospfv3-1]router-id 4.4.4.4
[r4-GigabitEthernet0/0/0]ospfv3 1 area  0
[r4-GigabitEthernet0/0/1]ospfv3 1 area  0
[r5-ospfv3-1]router-id 5.5.5.5
[r5-GigabitEthernet0/0/0]ospfv3 1 area  0
[r5-GigabitEthernet0/0/1]ospfv3 1 area  0
[r6-ospfv3-1]router-id 6.6.6.6
[r6-GigabitEthernet0/0/0]ospfv3 1 area  0
[r6-GigabitEthernet0/0/1]ospfv3 1 area  0

 R5可以Ping通R3


[r5]ping ipv6 2002::1
  PING 2002::1 : 56  data bytes, press CTRL_C to break
    Reply from 2002::1 
    bytes=56 Sequence=1 hop limit=63  time = 50 ms
    Reply from 2002::1 
    bytes=56 Sequence=2 hop limit=63  time = 20 ms
    Reply from 2002::1 
    bytes=56 Sequence=3 hop limit=63  time = 30 ms
    Reply from 2002::1 
    bytes=56 Sequence=4 hop limit=63  time = 30 ms
    Reply from 2002::1 
    bytes=56 Sequence=5 hop limit=63  time = 20 ms

  --- 2002::1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 20/30/50 ms

3.ripng宣告

[r7]ripng 1
[r7-ripng-1]	
[r7-GigabitEthernet0/0/1]ripng 1 enable 
[r8-ripng-2]q
[r8-GigabitEthernet0/0/0]ripng 2 enable 
[r10-GigabitEthernet0/0/1]ripng 1 enable 
[r11-GigabitEthernet0/0/0]ripng 1 enable 

4.静态路由

[r2]ip route-static 29.1.1.0 24 91.1.1.1
[r10]ip route-static 29.1.1.0 24 91.1.1.1
[r2]ipv6 route-static 0::0 0 2001::2
[r3]ipv6 route-static 0::0 0 2001::1
[r4]ipv6 route-static 0::0 0 2002::1
[r5]ipv6 route-static 0::0 0 2003::1
[r6]ipv6 route-static 0::0 0 2004::1

5.R1R2之间V4V6同时工作

[r1-GigabitEthernet0/0/0]ipv6 address 2002:0:0c10:0101::/48
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ip address 12.1.1.1 255.255.255.0 
 ipv6 address 2002:0:C10:101::/48 
#
[r2-GigabitEthernet0/0/0]ipv6 address 2002:0:0c01:0102::/48
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ip address 12.1.1.2 255.255.255.0 
 ipv6 address 2002:0:C01:102::/48 
#

6.R2做NAT

[r2]acl 2000
[r2-acl-basic-2000]rule permit source 12.1.1.0 0.0.0.255
[r2-GigabitEthernet0/0/0]nat outbound 2000

7.BGP建立

 ipv6-family unicast
  undo synchronization
  network 3:: 64 
  import-route ospfv3 1
  peer 4::4 enable
  peer 4::4 next-hop-local 
#
  import-route ospfv3 1
  peer 3::3 enable
  peer 3::3 reflect-client
  peer 3::3 next-hop-local 
  peer 5::5 enable
  peer 5::5 reflect-client
  peer 5::5 next-hop-local 
[r5-bgp]peer 6::6 as	
[r5-bgp]peer 6::6 as-number 64512	
[r5-bgp]peer 6::6 connect-interface LoopBack 0	
[r5-bgp]peer 6::6 ebgp-max-hop 2	
[r5-bgp-af-ipv6]peer 6::6 enable 	
[r5-bgp]peer 6::6 connect-interface LoopBack 0 5::5

[r6]bgp 64512
[r6-bgp]con	
[r6-bgp]confederation id	
[r6-bgp]confederation id 1
[r6-bgp]rou	
[r6-bgp]route-select
[r6-bgp]router-id 6.6.6.6
[r6-bgp]pe	
[r6-bgp]peer 5::5 as	
[r6-bgp]peer 5::5 as-number 64511
[r6-bgp]pe	
[r6-bgp]peer 5::5 con	
[r6-bgp]peer 5::5 connect-interface l	
[r6-bgp]peer 5::5 connect-interface l0 6::6
                                    ^
Error: Wrong parameter found at '^' position.
[r6-bgp]q
[r6]int l0
[r6-LoopBack0]ipv	
[r6-LoopBack0]ipv6 
[r6]int l0
[r6-LoopBack0]ipv	
[r6-LoopBack0]ipv6 en	
[r6-LoopBack0]ipv6 enable 
[r6-LoopBack0]ipv	
[r6-LoopBack0]ipv6 ad	
[r6-LoopBack0]ipv6 address 6::6/64
[r6-LoopBack0]q

[r6]bgp 64512	
[r6-bgp]peer 5::5 connect-interface LoopBack 0	
[r6-bgp-af-ipv6]peer 5::5 enable 	
[r6-bgp-af-ipv6]peer 5::5 next-hop-local 	
[r6-bgp]peer 5::5 ebgp-max-hop 
[r6-bgp]peer 5::5 connect-interface LoopBack 0 6::6

7.做TUNNEL

	
[r3-Tunnel0/0/0]ipv6 enable 
[r3-Tunnel0/0/0]ipv6 address 3::3/64
[r3-Tunnel0/0/0]tunnel-protocol ipv6-ipv4 6to4 
[r3-Tunnel0/0/0]source g0/0/0

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值