HDU 1598 find the most comfortable road

 

find the most comfortable road

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6133    Accepted Submission(s): 2639


Problem Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。
 

Input
输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。
 

Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。
 

Sample Input
      
      
4 4 1 2 2 2 3 4 1 4 1 3 4 2 2 1 3 1 2
 

Sample Output
      
      
1 0
 

Author
ailyanlu
 

Source
 

Recommend
8600


题意:给定一个图,求两点间路径上,两条边的最大权值差。


思路:利用kruskal算法的方法。对边排序,从最小的边开始枚举,依次添加比它大的边,知道所给的两个点连通,用最后一条边的权值减去开始枚举的那条边的权值。维护的最大值就是答案。和这一题一样的题还有POJ 3522 Slim Span这篇博客写的详细一点


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const int MAX_V = 205;
const int MAX_E = 1004;
const int INF = INT_MAX;

int V, E;
int par[MAX_V];
int ran[MAX_V];
int start, en;

void init(int n)
{
    for(int i = 0; i < n; ++i) {
        par[i] = i;
        ran[i] = 0;
    }
}

int fin(int x)
{
    if(par[x] == x) {
        return x;
    } else {
        return par[x] = fin(par[x]);
    }
}

bool same(int x, int y)
{
    return fin(x) == fin(y);
}

void unite(int x, int y)
{
    x = fin(x);
    y = fin(y);
    if(x == y) {
        return ;
    }
    if(ran[x] < ran[y]) {
        par[x] = y;
    } else {
        par[y] = x;
        if(ran[x] == ran[y]) {
            ran[x]++;
        }
    }
}

struct edge {
    int u, v, cost;
};

bool comp(const edge & e1, const edge & e2)
{
    return e1.cost < e2.cost;
}

edge es[MAX_E];

int kruskal(int t)
{
    init(V);
    for(int k = t; k < E; ++k) {  //枚举每一条边
        edge e = es[k];
        if(!same(e.u, e.v)) {
            unite(e.u, e.v);
        }
        if(same(start, en)) {  //判断这两个点是否连通
            return e.cost - es[t].cost;
        }
    }
    return INF;
}

int main()
{
    while(scanf("%d%d", &V, &E) != EOF) {
        for(int i = 0; i < E; ++i) {
            scanf("%d%d%d", &es[i].v, &es[i].u, &es[i].cost);
            es[i].v--;
            es[i].u--;
        }
        int q;
        scanf("%d", &q);
        sort(es, es + E, comp);
        for(int i = 0; i < q; ++i) {
            scanf("%d%d", &start, &en);
            start--;
            en--;
            int ans = INF;
            for(int j = 0; j < E; ++j) {
                ans = min(ans, kruskal(j));
            }
            if(ans == INF) {
                cout << -1 << endl;
            } else {
                printf("%d\n", ans);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值