poj 2229

Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 17820 Accepted: 6984

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

这一题想到了思路很简单,但是却很有意思。

题目大意是将一个数表示成二进制的和,问总共有多少种表达的方式。

思路是对于n为奇数的情况,因为拆开之后一定有个1,所以和n-1的情况相同。n为偶数的情况时,又分为两种情况,有1和无1,有1时和n-2相同(因为分出两个1),无1和n/2相同(因为所有的数都可以被2整除)。


#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 1e6 + 4;
const int mode = 1e9;
int dp[maxn];

int main()
{
    int n;
    dp[1] = 1;
    dp[2] = 2;
    scanf("%d", &n);
    for(int i = 3; i <= n; ++i) {
        if(i % 2 == 1) {
            dp[i] = dp[i - 1];
        } else {
            dp[i] = (dp[i - 2] + dp[i / 2]) % mode;
        }
    }
    printf("%d\n", dp[n]);
    return 0;
}



“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值