PAT A 1069 B 1019(甲级 乙级)

1069 The Black Hole of Numbers(20 分)

作者: CHEN, Yue

单位: 浙江大学

时间限制: 200 ms

内存限制: 64 MB

代码长度限制: 16 KB

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10^{4}).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

 


 

这道题读懂题目,注意细心就好了。

 


 

AC代码

#include <cstdio>
#include <algorithm>

using namespace std;

int d[4];

bool cmp(int, int);
void splitInt(int);
int mergeD();

int main(void) {
	int initNum;
	
	scanf("%d", &initNum);
	if(initNum % 1111 == 0) {
		printf("%d - %d = 0000\n", initNum, initNum);
	} else {
		int result = initNum;
		do {
			int nonIncre, nonDecre;
			splitInt(result);
			sort(d, d + 4, cmp);
			nonIncre = mergeD();
			sort(d, d + 4);
			nonDecre = mergeD();
			result = nonIncre - nonDecre;
			printf("%04d - %04d = %04d\n", nonIncre, nonDecre, result);
		} while(result != 6174);
	}
	
	return 0;
}

bool cmp(int a, int b) {
	return a > b;
}

void splitInt(int a) {
	for(int i = 0; i < 4; ++i) {
		d[i] = a % 10;
		a /= 10;
	}
}

int mergeD() {
	int result = 0;
	for(int i = 0; i < 4; ++i) {
		result = 10 * result + d[i];
	}
	
	return result;
}

 


 

如有错误,欢迎指摘。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值