【PAT甲级A1069】The Black Hole of Numbers (20分)(c++)

1069 The Black Hole of Numbers (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10​4​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题意:

将一个数的最大排序和最小排序组成的数相减,得到的数按照这一规矩执行,最终将得到6174,将这个过程输出。

思路:

将数字按字符串保存,利用字符串排序,主要用到字符串转数字stoi(),和数字转字符串to_string()的应用。(注意:当输入不满4位时要补零,当输入为6174时也要输出一次)。

参考代码:

#include <iostream>
#include <algorithm>
#include <string>

using namespace std;

bool cmp(char a, char b) {
    return a > b;
}

int main() {
    string str;
    cin >> str;
    do {
        while (str.length() < 4)
            str = "0" + str;
        sort(str.begin(), str.end(), cmp);
        int maxi = stoi(str);
        sort(str.begin(), str.end());
        int mini = stoi(str);
        if (maxi - mini != 0) {
            printf("%04d - %04d = %04d\n", maxi, mini, maxi - mini);
            str = to_string(maxi - mini);
        } else {
            printf("%04d - %04d = 0000\n", maxi, mini);
            break;
        }
    } while (str != "6174");
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值