PAT A1069

1069 The Black Hole of Numbers (20分)
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10
​4
​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767

Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:
2222

Sample Output 2:
2222 - 2222 = 0000

这道题很有借鉴意义 用to_array函数将数字转化为数组 用to_digit函数将数组转化为数字,函数思想,数组应用无疑刷题中是最重要的两个东西

#include<cstdio>
#include<algorithm>
using namespace std;
bool cmp(int a, int b){
    return a > b;
}
 void to_array(int n, int num[]){//这里若是将void函数换成int to_arry会运行超时
    for(int i = 0; i < 4; i++){
        num[i] = n%10;
        n /= 10;
    }
}
int to_digit(int num[]){
    int sum = 0;
    for(int i = 0; i < 4; i++){
        sum = 10*sum + num[i];
    }
    return sum;
}
int main(){
    int n, max, min;
    scanf("%d", &n);

    int num[5];
    while(1){
    to_array(n, num);
    sort(num, num + 4, cmp);
    max = to_digit(num);
    sort(num, num+4);
    min = to_digit(num);
    n = max - min;
    printf("%.4d - %.4d = %.4d\n", max, min, n);
    if(n == 6174 || n == 0) break;
}

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值