1039 Course List for Student(25 分)
作者: CHEN, Yue
单位: 浙江大学
时间限制: 600 ms
内存限制: 64 MB
代码长度限制: 16 KB
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
这道题英语没有难词,而且稍微了解C++的STL容器之后,这道题还是没有难度的。
但是使用map<string, vector<int> >的组合会导致超时,这可能是由于cin cout操作比较耗时再加上STL容器本身会消耗一定时间所导致的。
那么我们就考虑另一种方法实现类似map的功能,我们可以利用人名为3个大写字母+1位数字的固定格式来进行string -> int 的映射,大写字母一共有26个,可以将其当做3位26进制来将其和10进制进行互相转换,最后的一位数字在计算完26进制所对应的数字之后直接添加到末尾即可,那么就要开一个足够大的数组来一一对应每一个可能的名字,也就是 26 * 26 * 26 * 10 = 466560 左右的规模,开一个大小为5 * 的数组我们还是可以接受的,所以就可以使用 vector<int> 型的数组来存放每个学生以及所选的课程。
AC代码:
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 26 * 26 * 26 * 10 + 10;
vector<int> nameMap[maxn];
int getStringId(char []);
int main() {
int n, k;
scanf("%d%d", &n, &k);
for(int i = 0; i < k; ++i) {
int course, ni;
scanf("%d%d", &course, &ni);
for(int j = 0; j < ni; ++j) {
char sname[6];
scanf("%s", sname);
nameMap[getStringId(sname)].push_back(course);
}
}
for(int i = 0; i < n; ++i) {
char sname[6];
scanf("%s", sname);
int id = getStringId(sname);
sort(nameMap[id].begin(), nameMap[id].end());
printf("%s %d", sname, nameMap[id].size());
for(vector<int>::iterator it = nameMap[id].begin(); it < nameMap[id].end(); ++it) {
printf(" %d", *it);
}
printf("\n");
}
return 0;
}
int getStringId(char sname[]) {
int id = 0;
for(int i = 0; i < 3; ++i) {
id = id * 26 + (sname[i] - 'A');
}
id = id * 10 + (sname[3] - '0');
return id;
}
会产生超时的代码这里也放一下,只是速度较慢但是思想是相同的:
#include <cstdio>
#include <iostream>
#include <map>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
int main() {
int n, k;
map<string, vector<int> > nameMap;
scanf("%d%d", &n, &k);
for(int i = 0; i < k; ++i) {
int course, ni;
scanf("%d%d", &course, &ni);
for(int j = 0; j < ni; ++j) {
string sname;
cin >> sname;
nameMap[sname].push_back(course);
}
}
for(int i = 0; i < n; ++i) {
string fsn;
cin >> fsn;
printf("%s %d", fsn.c_str(), nameMap[fsn].size());
if(nameMap[fsn].size() != 0) {
printf(" ");
vector<int>::iterator ibegin = nameMap[fsn].begin();
vector<int>::iterator iend = nameMap[fsn].end();
sort(ibegin, iend);
for(vector<int>::iterator it = ibegin; it < iend; ++it) {
if(it != ibegin) {
printf(" ");
}
printf("%d", *it);
}
}
printf("\n");
}
return 0;
}
如有错误,欢迎指摘。