PAT甲级 A1039

PAT甲级 A1039

题目详情

1039 Course List for Student (25分)
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N(≤200) are given in a line. Then in the next line, N​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

解题思路

这题最基本的想法就是直接搜索。直接搜索耗费大量的时间空间,30分的算法题肯定不是简单的暴力搜索能够解决的。因此我们需要进行时间压缩的操作。

解题思路一

这道题我的第一解题思路就是用一个数据结构表示课程,数据结构包含课程的编号以及一个400000初始大小的默认数组,用一个map<string,int>将每一个输入的学生变成一个int的编号,如果该课程中拥有该学生,就将该学生的编号的数组赋值为1,否则为0.在遍历学生名字时就查找相关课程的指定数组就可以实现输出。这种方法是典型的空间换时间,用散列表减少了搜索的时间,此时代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;
class cl {//存储课程信息
public:
	int no;
	int student[41000] = { 0 };
};
map<string, int> names;
int ano = 0;
vector<cl> course;
int stringtoint(string a) {
	if (names.find(a) == names.cend()) {
		names[a] = ano;
		int temp = ano; ano++;
		return temp;
	}
	else {
		return names[a];
	}
}
int main() {
	int queno; int N;
	cin >> queno>>N; 
	for (int i = 0; i < N; i++) {
		int nos; int studentsno;
		cin >> nos >> studentsno;
		cl temp;
		temp.no = nos;
		for (int j = 0; j < studentsno; j++) {
			string name; cin >> name;
			int qs = stringtoint(name);
			temp.student[qs] = 1;
		}
		course.push_back(temp);
	}
	vector<string> names;
	for (int i = 0; i < queno; i++) {
		string temp; cin >> temp;
		names.push_back(temp);
	}
	for (int i = 0; i < names.size(); i++) {
		cout << names[i];
		int sno = stringtoint(names[i]);
		vector<int> courseno;
		for (int j = 0; j < course.size(); j++) {
			if (course[j].student[sno] == 1) {
				courseno.push_back(course[j].no);
				continue;
			}
		}
		cout << " " << courseno.size();
		sort(courseno.begin(), courseno.end());
		for (int j = 0; j < courseno.size(); j++) {
			cout << " " << courseno[j];
		}
		cout << '\n';
	}
}

上面的代码本来以为可以AC 但是最后一个搜索点存在段错误,应该是堆栈溢出问题,空间太大。只能拿到23分

解题思路二

转换上述的思路,还是需要map作为辅助工具,此时对于每个学生建立一个map对应的向量存储课程编号,只要把每个学生所选的课存入学生map对应的向量中,访问时进行直接输出(先从小到大排序)就可以同时减少搜索时间和存储空间。需要注意的是,部分整型输出需要采用scanf,用cin输入容易造成超时。此时的AC代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;
map<string, vector<int>> trans;
int main() {
	int queno; int N;
	cin >> queno>>N; 
	for (int i = 0; i < N; i++) {
		int nos; int studentsno;
		scanf("%d %d", &nos, &studentsno);
		for (int j = 0; j < studentsno; j++) {
			string name; cin >> name;
			trans[name].push_back(nos);
		}
	}
	vector<string> names;
	for (int i = 0; i < queno; i++) {
		string temp; cin >> temp;
		names.push_back(temp);
	}
	for (int i = 0; i < names.size(); i++) {
		cout << names[i] << " ";
		cout << trans[names[i]].size();
		sort(trans[names[i]].begin(), trans[names[i]].end());
		for (int j = 0; j < trans[names[i]].size(); j++) {
			cout << " " << trans[names[i]][j];
		}
		cout << '\n';
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值