PAT A 1052(甲级)

1052 Linked List Sorting(25 分)

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 10^{5}) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10^{5},10^{5}​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

 


 

这道题虽然看起来不难,也很容易想到用静态链表去做,但是一定要注意两点:

1.给出来的节点不一定都在链表上,所以需要在结构体中加入标志位

2.更重要的是可能整个链表没有节点,所以这个时候需要特判输出

 

了解这些之后思路就较清晰了,建立结构体,存储data,next,flag和自身的address(用于排序后的输出),然后读取输入,遍历链表记录链表中的节点个数,如果个数为0,特判并输出,如果不为零,就对那些在链表中的节点进行排序,然后从 0 到 num - 1进行输出即可。

 


 

AC代码:

#include <cstdio>
#include <algorithm>

using namespace std;

const int maxn = 100010;

struct Node {
    int add, key, next;
    bool exist;
} node[maxn];

bool cmp(Node, Node);

int main() {
    int n, head;

    for(int i = 0; i < maxn; ++i) {
        node[i].exist = false;
    }

    scanf("%d%d", &n, &head);

    for(int i = 0; i < n; ++i) {
        int address, k, ne;
        scanf("%d%d%d", &address, &k, &ne);
        node[address].add = address;
        node[address].key = k;
        node[address].next = ne;
    }

    int p = head, nnum = 0;
    while(p != -1) {
        node[p].exist = true;
        ++nnum;
        p = node[p].next;
    }

    if(nnum == 0) {
        printf("0 -1\n");
        } else {

        sort(node, node + maxn, cmp);

        printf("%d %05d\n", nnum, node[0].add);
        for(int i = 0; i < nnum; ++i) {
            printf("%05d %d ", node[i].add, node[i].key);
            if(i == nnum - 1) {
                printf("-1\n");
            } else {
                printf("%05d\n", node[i + 1].add);
            }
        }
    }

    return 0;
}


bool cmp(Node a, Node b) {
    if(!a.exist || !b.exist) {
        return a.exist;
    } else {
        return a.key < b.key;
    }
}

 


 

如有错误,欢迎指摘。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值